好的代码像粥一样,都是用时间熬出来的

python3.5.2下载安装Tensorflow

安装的翻译官方文档 极客学院

按照文档直接安装可能会安装不上,我使用的是virtualenv安装方式

下面说一下遇到的问题

Ubuntu16.04默认virtualenv虚拟机是python2.7版本的,这里先弄一个python3.5版本的

1
virtualenv --system-site-packages -p /usr/bin/python3.5 ~/tensorflow3

打开virtualenv镜像

1
2
3
cd tensorflow3
#切换工作路径到镜像
source bin/activate

从官网下载的https://storage.googleapis.com/tensorflow/linux/cpu/tensorflow-0.8.0-cp34-cp34m-linux_x86_64.whl

直接安装会报出如下错误

Cannot install tensorflow on fresh ubuntu partition: tensorflow-0.8.0-cp34-cp34m-linux_x86_64.whl is not a supported wheel on this platform

因为官方安装包是py3.4版本,直接安装的话可能会出现问题,这里有个解决方法

主要步骤

1
2
3
4
5
6
#通过wget命令获取whl
$ wget https://storage.googleapis.com/tensorflow/linux/cpu/tensorflow-0.8.0-cp34-cp34m-linux_x86_64.whl
#将whl重命名
$ mv tensorflow-0.8.0-cp34-cp34m-linux_x86_64.whl tensorflow-0.8.0-py3-none-linux_x86_64.whl
#使用--ignore-installed标记防止错误的产生,权限问题的话加上sudo
$ pip install --ignore-installed --upgrade tensorflow-0.8.0-py3-none-linux_x86_64.whl
坚持原创技术分享,您的支持将鼓励我继续创作!